search the web

Sunday, February 21, 2016

Initial configuration of Cisco routers

Initial configuration of Cisco routers

R1-2500
---------------------------------------------------
conf t
hostname R1-2500
enable secret cisco

line consol 0
password cisco
login
logging synchronous

exec-timeout 30 15
!This command means that if there is no activity through console for 30min 15 sec logout.
exit

line vty 0 4
password cisco
login
loggin synch
exit

no ip domain-lookup


banner motd #
-------------------------------------------------------------------------
Unauthorized access not allowed
-------------------------------------------------------------------------
#

!Configure IP address on R1

interface s0
ip address 192.168.1.2 255.255.255.0
no shut
exit
exit

write memory

---------------------------------------------------
BB
---------------------------------------------------
conf t
hostname BB-2610
enable secret cisco

line consol 0
password cisco
login
logging synchronous

exec-timeout 30 15
!This command means that if there is no activity through console for 30min 15 sec logout.
exit

line vty 0 4
password cisco
login
loggin synch
exit

no ip domain-lookup

interface s1/0
ip address 192.168.1.1 255.255.255.0
clock rate ?
clock rate 64000
no shut
exit

interface s1/1
ip address 192.168.2.1 255.255.255.0
no shut
clock rate 56000
exit

interface s1/2
ip address 192.168.3.1 255.255.255.0
no shut
clock rate 64000
exit

interface s1/3
ip address 192.168.4.1 255.255.255.0
no shut
clock rate 64000
exit

---------------------------------------------------
R2
---------------------------------------------------
conf t
hostname R2
enable secret cisco

line consol 0
password cisco
login
logging synchronous

exec-timeout 30 15
!This command means that if there is no activity through console for 30min 15 sec logout.
exit

line vty 0 4
password cisco
login
loggin synch
exit

no ip domain-lookup

interface s0
ip address 192.168.2.2 255.255.255.0
no shut
exit

---------------------------------------------------
R3-2612
---------------------------------------------------
conf t
hostname R3-2612
enable secret cisco

line consol 0
password cisco
login
logging synchronous

exec-timeout 30 15
!This command means that if there is no activity through console for 30min 15 sec logout.
exit

line vty 0 4
password cisco
login
loggin synch
exit

no ip domain-lookup

interface s0/0
ip address 192.168.3.2 255.255.255.0
no shut
exit


! we have troubleshooting commands
show ip interface brief
!This shows the information about the interaces, you see their names, whether they up or down.

show interface s0/0
!this show s the details about the interface

!To check the cable type connected to an interface type
sh controllers s0/0

!To check the version
show version

!To check the routing table of the cisco router
show ip route
!A router can route to networks stated in the routing table.

Thursday, February 18, 2016

Free CCNA tutorials for android

Free CCNA tutorials

Download free CCNA tutorials for your android smartphone and learn CCNA on go
just click on the link below then click on download and then install it on your android smartphone
download Free CCNA tutorials for android

Wednesday, February 17, 2016

Configuring EIGRP updated

Configuring EIGRP updated

--------------------------------------------
R1
--------------------------------------------
show ip route
!Check the connected routes and advertise them through eigrp
conf t
router eigrp 100
!This command will enable eigrp for autonomous system 100, now the autonomous system must be same on all the routers to communicate through EIGRP.

network 192.168.100.0 0.0.0.255
!This command advertises the network through EIGRP
network 192.168.0.0
!Through this command we can also advertise the EIGRP, and it shows its ease of configuration like RIP.

no auto-summary
!The no auto-summary command tells eigrp not to summarize the route itself but eigrp has to look the mask. we do this because in the above command we advertised the network with default mask, now the eigrp will have a look at the interface and will pick the mask from there.
exit

--------------------------------------------------
R2
--------------------------------------------------
conf t
interface loop 0
ip address 172.16.0.1 255.255.255.0
no shut
exit
interface loop 1
ip address 172.16.1.1 255.255.255.0
no shut
exit
interface loop 2
ip address 172.16.2.1 255.255.255.0
no shut
exit
interface loop 3
ip address 172.16.3.1 255.255.255.0
no shut
exit
interface loop 4
ip address 172.16.4.1 255.255.255.0
no shut
exit
interface loop 5
ip address 172.16.5.1 255.255.255.0
no shut
exit
interface loop 6
ip address 172.16.6.1 255.255.255.0
no shut
exit

interface loop 7
ip address 172.16.7.1 255.255.255.0
no shut
exit

router eigrp 100
network 192.168.200.0 0.0.0.255
network 192.168.0.0 0.0.0.255
network 172.16.0.0 0.0.7.255
no auto-summary
exit
exit

---------------------------------------------------------
R3
---------------------------------------------------------
conf t
router eigrp 100
network 192.168.100.0
network 192.168.200.0
no auto-summary
exit
exit

Now to do route summarizaion on router 2
we apply the following commands
conf t
int s1
ip summary-address eigrp 100 172.16.0.0 255.255.248.0
exit
int e0
ip summary-address eigrp 100 172.16.0.0 255.255.248.0
exit

Unequal cost load balancing on R3
conf t
router eigrp 100
varianc 20
!This command tells eigrp to load balance on other paths, if they are even 20 times bad then the primary path.

To clear the routing table
clear ip route *

to clear the eigrp neighbors

clear ip eigrp neighbors

After this command new neighbor relationship will be formed


For initial configuration of Router, Switch or AP click
initial configuration of Router, Switch or AP



Saturday, February 13, 2016

CONFIGURING VLANS

CONFIGURING VLANS

-----------------------
There are four steps to configure VLANS

1.Configure Trunks (EtherChannel)
2.Configure VTP
3.Configure VLANS
4.Assign Ports to VLAN.

Configure on WC_S1
1.Configure Trunks
WC_S1

interface range fa0/23 -24
switchport mode Trunk
!This command hardcodes these ports as trunk port.
no shut
exit

For configuring Ether-channel we do
interface fa0/23 -24
channel-group 1 mode desirable
!means the ports are desirable to become one channel and this command will make a new port called as port channel 1.
exit
interface po1

switchport mode trunk
no shut
exit


WC_S2

interface range fa0/23 -24
switchport mode Trunk
!This command hardcodes these ports as trunk port.
no shut
exit

interface fa0/23 -24
channel-group 1 mode desirable
!means the ports are desirable to become one channel and this command will make a new port called as port channel 1.
switchport mode trunk
no shut
exit

2.Configure VTP
WC_S1
conf t
vtp domain networkers
!this enables the vtp domain name as networkers
vtp password cisco
!This assigns the password so that no rogue switch can connect to our vtp domain.

vtp mode server (This is the default one)

WC_S2
conf t
vtp domain networkers
!this enables the vtp domain name as networkers
vtp password cisco
!This assigns the password so that no rogue switch can connect to our vtp domain.

vtp mode client

show vtp status
!shows the status of vtp,its revision number and the md5 hash. The md5 hash must be same between both the switches to share vlan information. MD5 hash is calculated from the vtp domain and vtp password.

show vlan brief
!shows the number of vlans in your switch.

3.Configure VLANS
WC_S1
conf t
vlan 10
name sales
exit
vlan 20
name IT
exit
vlan 30
name Engineering
exit

Now the vlan information must replicate from the vtp server to the client

WC_S2
show vlan brief
!you must see the vlans created.

4.Assign Ports to VLAN.
WC_s1
conf t
interfac range fa0/1 -10
switchport mode access
switchport access vlan 10
exit

WC_S2
conf t
int rang fa0/1 -12
switchport mode access
switchport access vlan 20
exit
interface range fa0/13 -15
switchport mode access
switchport access vlan 10
exit

interface range fa0/16 -20
switchport mode access
switchport access vlan 30
exit

show vlan brief
!you will see the ports that are mapped to each vlan.


For initial configuration of Router, Switch or AP click
initial configuration of Router, Switch or AP


Wednesday, February 10, 2016

Configuring Switchport Port Security

Configuring Switchport Port Security


show ip int brief
!shows the details about the ports on our switch

conf t
interface fa0/1
switchport mode access
!This command hardcodes the port to be access port and only hosts can connect to it.
switchport port-security
!enables port security on this port

switchport port-security maximum 1
!This is the default and means to accept only one mac address on this port.

switchport port-security mac-address 00:11:22:33:44:55
!accept only this mac address on this port
OR
switchport port-security mac-address sticky
!means that stick whatever mac address is connected with you.

switchport port-security violation Protect|Restrict|shudown
Protect: ignore traffic from the violating mac address and do not show the log messages.
Restrict: ignore the traffic and show me the log message on the screen
shutdown: This is the default and means if some one is violating the rule so shutdown the port automati
cally.


conf t
interface range fa0/1 -22
!This command takes you inside all the above mentioned 22 ports.

show port-security
!shows the port security on all the interfaces.

show port-security int fa0/7
!shows the port secuirty information about fa0/7

---------------------------------------------
setting DUPLEX and speed on your Cisco switch
---------------------------------------------
int fa0/1
duplex half|full|auto

!default is auto

int fa0/1
speed 10|100|auto
!default is auto

For initial configuration of Router, Switch or AP click
initial configuration of Router, Switch or AP

Monday, February 8, 2016

Configuring Spanning Tree Protocol

Configuring Spanning Tree Protocol


show spanning-tree
!This command shows all the instances of STP running on this switch. It shows two portions, one showing the ROOTID which shows the information about the root switch showing its mac address, priority and many other things. The default priority is 32768. Now the stp adds the vlan id to the switch priotiry. and other thing it shows is the information about switch itself.

show spanning-tree
!shows all the instances of stp running- on this switch.

show spanning-tree vlan 1
!shows the stp for vlan 1

Now we configure WC_S1 as root
WC_S1
conf t
spanning-tree vlan 1,10,20 root primary
!now the switch becomes the root and it lowers the priority of the switch.

no spanning-tree vlan 1,10,20 root primary

Enabling PORTFAST on the switch
conf t
interface fa0/1 -20
switchport mode access
spanning-tree portfast
!on the all the ports portfast will be enabled and they will bypass the listening phase.

Enabling RAPID-STP on both S1 and s2
conf t

spanning-tree mode rapid-pvst
!we have to apply this command on both the switches.

for initial configuration of Router, switch or AP visit link below
initial configuration of Router, Switch or AP

Initial configuration of a router, switch or AP

Initial configuration of a router, switch or AP:


1. Loging through console port via
2. go to global configuration mode
3. Set hostname
4. Set username admin privilige password admin123
5. Set enable secret admin@123
6. Set ip address to targeted interface
7. ip address 172.30.57.1 255.255.255.0
8. ip default gateway 172.30.57.254
9. ip name-server 172.30.10.2
10.ip name-server 172.30.10.3
11.line vty 0 15
12.login local
13.line console 0
14.login local