search the web

Saturday, December 12, 2015

Configuring RIPv2

Configuring RIP

-----------------------------------
R3
-----------------------------------
show ip protocol
!check that no other protocol is running

show ip route
!note the connected routes

conf t
router rip
!This command enables rip on this router

network 192.168.30.0
!The network command does two thing. one which network to advertise and second on which interface to advertise the networks. Aso enables rip on that interface.
network 192.168.0.0
exit

----------------------------------
BB
----------------------------------
show ip route
conf t
router rip
network 192.168.30.0
network 192.168.20.0
network 192.168.10.0
exit


----------------------------------
R2
----------------------------------
show ip route
conf t
router rip
network 192.168.20.0
exit


------------------------------------
R1
------------------------------------
show ip route
conf t
router rip
network 192.168.10.0
exit

show ip route
!you will see routes learnt through R which means RIP. You will also see something like [120/1] here 120 means the administrative distance which defines how believable a routing protocol is? lower is better. and 1 defines the metric which is hop count in case of RIP.

show ip protocols
it shows the RIP running on this router.

now lets run the troubleshooting command debug to check the way RIP speaking routers communicate

debug ip rip
RIP: received v1 update from 192.168.30.1 on Serial0/0
*Mar  1 03:29:44.617:      192.168.10.0 in 1 hops
*Mar  1 03:29:44.617:      192.168.20.0 in 1 hops
R3-2612#
*Mar  1 03:29:57.302: RIP: sending v1 update to 255.255.255.255 via Serial0/0 (1
92.168.30.2)
*Mar  1 03:29:57.302: RIP: build update entries - suppressing null update
R3-2612#
*Mar  1 03:30:10.419: RIP: received v1 update from 192.168.30.1 on Serial0/0
*Mar  1 03:30:10.419:      192.168.10.0 in 1 hops
*Mar  1 03:30:10.419:      192.168.20.0 in 1 hops
R3-2612#
*Mar  1 03:30:22.852: RIP: sending v1 update to 255.255.255.255 via Serial0/0 (1
92.168.30.2)
*Mar  1 03:30:22.852: RIP: build update entries - suppressing null update

u all
disables all the debugs

terminal monitors
!shows the log messages if you are connected to router or switch through telnet.

Changing RIP to VERSION 2
conf t
router rip
version 2
exit

Go on each router and change the version to version 2


Thanks for visiting if there is any doubt or question about RIP v2 (routing information protocol) please write down in comments

for initial configuration of Router, switch or AP visit link below

initial configuration of Router, Switch or AP

Sunday, November 22, 2015

Configuring OSPF

Configuring OSPF

-----------------
Wild card mask= 0 means match and 255 mean dont care

255.255.255.255
-
255.255.255.0 [subnet mask]
---------------------------
0.0.0.255 [The result of this is the wild card mask]

-------------
R1
-------------
conf t
!loop back interfaces are logical interfaces that you configure manually and they are up all the time. Used for OSPF router-id.

int loop 0
ip address 10.50.0.1 255.255.255.0
no shut
exit
int loop 1
ip address 10.50.1.1 255.255.255.0
no shut
exit
int loop 2
ip address 10.50.2.1 255.255.255.0
no shut
exit
int loop 3
ip address 10.50.3.1 255.255.255.0
no shut
exit
int loop 4
ip address 10.50.4.1 255.255.255.0
no shut
exit
int loop 5
ip address 10.50.5.1 255.255.255.0
no shut
exit
int loop 6
ip address 10.50.6.1 255.255.255.0
no shut
exit
int loop 7
ip address 10.50.7.1 255.255.255.0
no shut
exit

do show ip route
!note the connencted networks

router ospf 1

!this command enables OSPF with process-id of 1. The process id only identifies the OSPF process. It is like applicatons running in windows with a process id visible in taskmanager.

route-id 1.1.1.1
!This manually assings a router-id to the router as 1.1.1.1


network 192.168.10.0 0.0.0.255 area 0
!This will enable ospf on the interface which has a network id of 192.168.10.0 and will put that interface in area 0
OR
network 192.168.0.0 0.0.255.255 area 0
!This will enable ospf on all those interfaces which has 192.168 common and will put them in area 0.
-------------------------
10.50.00000001.00000000
10.50.00000111.00000000
-----------------------
10.50.0.0/21
/21=255.255.248.0
wildcard mask
255.255.255.255
255.255.248.0
---------------
0.0.7.255
-------------------------

network 10.50.0.0 0.0.7.255 area 1
!This one command will advertise the whole list from 1050.0.0-1050.7.0

-------------------------
BB
------------------------
show ip route
conf t
router ospf 1
router-id 5.5.5.5
network 192.168.0.0 0.0.255.255 area 0
OR
network 192.168.10.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 0

exit


-------------------------
R3
-------------------------
show ip route
conf t
router ospf 1
network 192.168.30.0 0.0.0.255 area 0
netowrk 192.168.0.0 0.0.0.255 area 0
exit


--------------------------
R2
--------------------------
show ip route
conf t
router ospf 1
network 192.168.0.0 0.0.0.255 area 0
exit


ROUTE-SUMMARIZATION ON ROUTER 1
conf t
router ospf 1
area 1 range 10.50.0.0 255.255.248.0
!This command will summarize the routes.


show ip ospf neighbors
!shows the neighbor table
show ip ospf database
!shows the topology table

show ip route
!shows the routing table.



Thanks for visiting if there is any doubt or question about OSPF (Open Shortest Path First) please write down in comments

for initial configuration of Router, switch or AP visit link below

initial configuration of Router, Switch or AP

Monday, November 16, 2015

Configuring NAT

Configuring NAT

1.Identify the network to be translated
2.Add a default static route pointing to your ISP router
3.Label the interfaces ( And the label has an affect on the interfaces )
4.Apply ip nat command

R3
show ip route
conf t
access-list 1 permit 192.168.0.0 0.0.255.255
!through this we have allowed any network starting from 192.168. to be translated to the internet

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip name-server 4.2.2.2
!This command assigns a dns server addressexit
ping 192.168.1.1
conf t

ping google.com

ip domain-lookup
!enables dns lookup


interface e0
ip nat outside
exit
interface s0
ip nat inside
exit
!we have labled the interfaces and it will affect them as well.

ip nat inside source list 1 interface e0 overload
!please nat the addresses mentioned in the source list 1 and overload them on outside interface e0.

R1
conf t
access-list 1 permit 192.168.0.0 0.0.255.255
ip route 0.0.0.0 0.0.0.0 192.168.100.2
int s1/0
ip nat outside
exit
int e0/0
ip nat inside
exit
ip nat inside source list 1 interface s1/0 overload
i want to nat the addresses mentioned in source list 1 and please overload them on outside interface which is s1/0
exit


STATIC NAT ON R3
we want to map 192.168.1.12 to our R2's ip address 192.168.100.1. Any traffic coming to 192.168.1.12 will be sent to 192.168.100.1
first we label the R3's interface s1 which is connected to R2

conf t
int s1
ip nat inside
exit

ip nat inside source static 192.168.200.1 192.168.1.12
Please statically map the inside local address 192.168.200.1 to the inside global address 192.168.1.12.


PORT MAPPING
ip nat inside source static tcp 192.168.200.1 23 192.168.1.11 23
This command statically maps the port 23 of 192.168.1.11 to the port 23 of R2 192.168.200.1

DYNAMIC NAT
R3
show ip route
conf t
access-list 1 permit 192.168.0.0 0.0.255.255
!through this we have allowed any network starting from 192.168. to be translated to the internet

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip name-server 4.2.2.2
!This command assigns a dns server addressexit
ping 192.168.1.1
conf t

ping google.com

ip domain-lookup
!enables dns lookup


interface e0
ip nat outside
exit
interface s0
ip nat inside
exit
!we have labled the interfaces and it will affect them as well.
ip nat pool PUBADD 192.168.1.11 192.168.1.15 netmask 255.255.255.0
!We have created a pool of public address by name of PUBADD.

ip nat inside source list 1 pool PUBADD overload

!please nat the addresses mentioned in the source list 1 and overload them on outside pool of address which PUBADD.


Thanks for visiting if there is any doubt or question about NAT (Network Adress Translation) please write down in comments

for initial configuration of Router, switch or AP visit link below

initial configuration of Router, Switch or AP

Monday, November 9, 2015

Configuring INter-vlan Routing

Configure INter-vlan Routing


Configure the Switchpot as trunk

WC_S1
conf t
interface fa0/21
switchport mode trunk
exit

-------------------------------
R3
------------------------------
conf t
interface e0/0
ip address 192.168.0.1 255.255.255.0
no shut
exit
interface e0/0.10
encapsulation dot1q 10
!means the trunking protocol will be dot 1q and vlan 10 will able to access it
ip address 192.168.100.1 255.255.255.0
no shut
exit
interface e0/0.20
encapsulation dot1q 20
ip address 192.168.200.1 255.255.255.0
no shut
exit

for initial configuration of Router, switch or AP visit link below
initial configuration of Router, Switch or AP

Sunday, October 25, 2015

Configuring Frame-relay Point-To-Point

Configuring Frame-relay Point-To-Point


---------------------------------------
BB_Configuring Frame-relay switch
---------------------------------------
conf t
frame-relay switching
interface s1/1
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
frame-relay intf-type dce
clock rate 64000
frame-relay route 102 int s1/2 201
frame-relay route 103 int s1/3 301
no shut
exit

int s1/2
no ip address
encap frame-relay
frame-relay lmi-type cisco
frame-relay intf-type dce
clock rate 64000
frame-relay route 201 int s1/1 102
no shut
exit

int s1/3
no ip address
encap frame-relay
frame-relay lmi-type cisco
frame-relay intf-type dce
clock rate 64000
frame-relay route 301 int s1/1 103
no shut
exit

--------------------------------------------
R1
--------------------------------------------
conf t
int s0
encapsulation frame-relay
frame-relay lmi-type cisco
no ip address
exit
int s0.102 point-to-point
!this command enables sub interface on this router which is point to point.
ip address 192.168.2.1 255.255.255.0
no shut
frame-relay interface-dlci 102
exit
exit

interface s0.103 point-to-point
ip address 192.168.3.1 255.255.255.0
no shut
frame-relay interface-dlci 103
exit
exit

--------------------------------------------
R2
--------------------------------------------
conf t
int s0
no ip address
encap frame-relay
frame-relay lmi-type cisco
exit
int s0.201 point-to-point
ip address 192.168.2.2 255.255.255.0
no shut
frame-relay interface-dlci 201
exit
exit

-----------------------------------------------
R3
-----------------------------------------------
conf t
int s0/0
no ip add
encap frame-relay
frame-relay lmi-type cisco
exit
int s0/0.103 point-to-point
ip address 192.168.3.2 255.255.255.0
no shut
frame-relay interface-dlci 301
exit
exit

for initial configuration of Router, switch or AP visit link below
initial configuration of Router, Switch or AP

Sunday, October 18, 2015

Configuring Multipoint Frame Relay Scenario

Configuring Multipoint Frame Relay Scenario


COnfiguring FRAME-RELAY Switch.
-------------------------------------------
BB(configuring BB as FR switch)
conf t
frame-relay switching
!we enable frame-relay switching

int s1/1
no ip address
encapsulation frame-relay
!enables frame-relay encapsulation on this interface
frame-relay lmi-type cisco
!enables the signaling lanuage as cisco on this interface
frame-relay intf-type dce
!tells the device that the interface type connected is dce
clock rate 64000

!now we are creating virtual circuit
frame-relay route 102 interface s1/2 201
!we create a virtual circuit 102 with a destination of interface s1/2 and destination dlci 201
frame-relay route 103 interface s1/3 301
exit
interface s1/2
encapsulation frame-relay
frame-relay lmi-type cisco
frame-relay intf-type dce
clock rate 64000
frame-relay route 201 int s1/1 102
no shut
exit

interface s1/3
encapsulation frame-relay
frame-relay lmi-type cisco
frame-relay intf type dce
clock rate 64000
frame-relay route 301 int s1/1 103
no shut
exit

----------------------------------------------------
R1
----------------------------------------------------
conf t
int s0
encapsulation frame-relay
frame-relay lmit-type cisco
ip address 192.168.1.1 255.255.255.0
no shut
frame-relay map 192.168.1.2 102 broadcast
!means that map the remote ip 192.168.1.2 with the local dlci 102 and also enable broadcast on it so that it forwards the broadcast or multicast traffic of the routing protcols
frame-relay map ip 192.168.1.3 103 broadcast
exit


--------------------------------------------------------
R2
--------------------------------------------------------
conf t
int s0
encapsulation frame-relay
frame-relay lmi-type cisco
ip address 192.168.1.2 255.255.255.0
frame-relay map 192.168.1.1 201 broadcast
frame-relay map 192.168.1.3 201 broadcast
!we mapped the ip address of 192.168.1.3 through 201 dlci which is local to us
no shut
exit

-------------------------------------------------------
R3
-------------------------------------------------------
conf t
int s0/0
encap frame-relay
frame-relay lmi-type cisco
ip address 192.168.1.3 255.255.255.0
frame-relay map ip 192.168.1.1 301 broadcast
frame-relay map ip 192.168.1.2 301 broadcast
exit
exit

show frame-relay map
!see the whether the mappings are active or inactive, shows details about mappings

show frame-relay lmi
!shows the details about frame-relay lmi, signaling statistics. check the messages sent and messages recieved, they must be equal to each other. Also check if there is lmi mismatch, check the timeouts.

SPLIT HORIZON PROBLEM
on router 1
conf t
int s0
no ip split-horizon eigrp 10
exit


for initial configuration of Router, switch or AP visit link below
initial configuration of Router, Switch or AP

Sunday, October 11, 2015

How to configure EIGRP

Configuring EIGRP

----------------------------------------------------------------
R4
---------------------------------------------------------------
conf t
no router ospf 1

router eigrp 10
!This 10 is the autonomous system number, it must be same on all eigrp speaking routers.
!it is from 1 - 65535

network 192.168.4.0
!If we advertise network like the above command, it will advertise the network with default mask. but we can also advertise with wild card mask

network 192.168.4.0 0.0.0.255
network 192.168.5.0 0.0.0.255
exit

----------------------
BB
----------------------
conf t
no router ospf 1

router eigrp 10
network 192.168.0.0 0.0.255.255

!Through this command we have instructed EIGRP to enable EIGRP on all those interfaces which starts from 192.168 and dont care about the last 2 octet
exit

------------------------------------
R3
------------------------------------
conf t
no router ospf 1
router eigrp 10
network 192.168.3.0 0.0.0.255
network 192.168.5.0 0.0.0.255
exit

-----------------------------------------
R1
-----------------------------------------
conf t

interface loop 0
ip address 172.16.0.1 255.255.255.0
no shut
exit
interface loop 1
ip address 172.16.1.1 255.255.255.0
no shut
exit
interface loop 2
ip address 172.16.2.1 255.255.255.0
no shut
exit
interface loop 3
ip address 172.16.3.1 255.255.255.0
no shut
exit
interface loop 4
ip address 172.16.4.1 255.255.255.0
no shut
exit
interface loop 5
ip address 172.16.5.1 255.255.255.0
no shut
exit
interface loop 6
ip address 172.16.6.1 255.255.255.0
no shut
exit

interface loop 7
ip address 172.16.7.1 255.255.255.0
no shut
exit

no router ospf 1

router eigrp 10
network 192.168.1.0
network 172.16.0.0

!IF we advertise the networks like we did above, R1 will tell all the routers that all the networks of class B 172.16.0.0 is here with me.

!The command that we will apply is to instruct EIGRP not to auto-summarize. It is recommened to apply the no auto-summary on all the eigrp routers, because it is good to manually configure EIGRP rather than leaving it by default.

no auto-summary



! To summarize route towards the backbone we apply the summary address on the interface connected to backbone

R1
conf t
interface s0
ip summary-address eigrp 10 172.16.0.0 255.255.248.0
exit
exit

for initial configuration of Router, switch or AP visit link below
initial configuration of Router, Switch or AP

Thursday, October 8, 2015

Configuring cisco switch as dhcp server

configuring cisco switch as dhcp server


conf t
ip dhcp pool internal
!This enables dhcp pool as internal

network 192.168.0.0 /24
!tells the network from which the switch will assign ip addresses.

default-router 192.168.0.1
!default router here means the default gateway

dns-server 4.2.2.2

domain-name networkers.af

lease 0 2
!enables lease for 2 days
exit

ip dhcp excluded-address 192.168.0.1 192.168.0.10
exit

service dhcp
!this command enables dhcp service

show ip dhcp binding
!shows dhcp ip to mac binding

for initial configuration of Router, switch or AP visit link below
initial configuration of Router, Switch or AP

Monday, October 5, 2015

Cisco Discovery Protocol

Cisco Discovery Protocol

CDP or cisco discovery Protocol is the protocol used for gathering information about the cisco devices on the network.
CDP is cisco proprietary which means that it works on cisco devices only.
Enabling CDP on a cisco device enables its neighbors to gather information about that device. Each and every cisco switch or router sends cdp information also called CDP advertisement to the neighboring devices which contains the information about that device at each specific intervals. meaning the routers or switches are doing cdp advertisement after every 60 seconds by default. There are four main commands which are:

show cdp neighbor
show cdp entry
cdp run
cdp enable


BB Router
conf t
cdp run
no cdp run
This command enables or disables cdp globally.

int s1/1
cdp enable
no cdp enable
This command enables or disables the cdp on per interface bases.
exit
exit
show cdp neighbors
!shows the directly connected neighbors and all their information.
show cdp entry {DEVICE-ID}
!shows informatin about a specific device.

for initial configuration of Router, switch or AP visit link below
initial configuration of Router, Switch or AP

Sunday, October 4, 2015

mac filtering



Mac filtering

Configuring ACL-access list

Configuring ACL on Cisco Routers.


1.Deny Any Traffic from 192.168.0.103 to R1
2.Deny telnet from 192.168.0.103 to R1
3.Block any traffic to networkers.af
4.permit only telnet traffic from 192.168.0.103 and deny all others
5.Apply reflexive ACL on R1 so that on the traffic can be allowed from R1.

1.Deny Any Traffic from 192.168.0.103 to R1
R1
conf t
access-list 1 deny 192.168.0.103 0.0.0.0
access-list 1 permit any
int e0
ip access-group 1 in
!This command applies access-list on interface e0 inbound
exit
--------------------------
Same example with NAmed ACL
---------------------------
conf t
ip access-list standard DENYHOST
deny 192.168.0.103 0.0.0.0
permit any
exit
int e0
ip access-group DENYHOST in
exit

2.Deny telnet from 192.168.0.103 to R1
conf t
no access-list 1
access-list 10 deny 192.168.0.103 0.0.0.0
line vty 0 4
access-class 10 in
!This command applies ACL 10 on line vty inbound

3.Block any traffic to networkers.af
R1
conf t
access-list 101 deny tcp any host 205.209.127.53 eq www
OR
access-list 101 deny tcp 192.168.0.0 0.0.255.255 host 205.209.127.53 eq www

4.permit only telnet traffic from 192.168.0.103 and deny all others
no access-list 101

access-list 100 permit tcp host 192.168.0.103 host 192.168.0.1 eq telnet
!This command permits only host 192.168.0.103 to the router 1 which has an ip 192.168.0.1. As we know there is a deny all at the end so all others will be automatically denied from doing telnet to the R1 VTY lines.

line vty 0 4
access-class 100 in
exit

show access-lists

---------------
NAMED ACL
--------------

conf t
ip access-list standard DENYHOST
deny 192.168.0.103 0.0.0.0
permit any
exit
int e0
ip access-group DENYHOST in
exit


when you do show access-list, you will some some numbers before the acl entry.
that number is called the sequence number and you can edit the acl with that
for example
ip access-list standard DENYHOST
no 20
15 permit any
by doing no 20, it will remove the acl entry number 20 and will add a new entry with the second command.


for initial configuration of Router, switch or AP visit link below
initial configuration of Router, Switch or AP

download and install cisco packet tracer


Wednesday, September 30, 2015

ACL-Access List

ACL-Access List
ACL is used to maintenance that which traffics should be passed on an interface and which traffics should not.  
·         Controlling of outgoing and incoming traffics on an interface.
·         Controlling of virtual terminal access (Telnet)
·         They are specified by either  name or number
·         Prior to Cisco’s IOS version 11.2, ACL could be specified only by number.
·         It is a sequential collection of permit deny criteria that are checked against IP packets
·         Wildcard Mask must me assigned
o   0 in wildcard mask means: allow
o   255 means: don’t care
Basically there are two kinds of ALCs
1.     Standard ACL
a.      The source IP address is determined for matching criteria, not destination IP Address.
b.      1-99
c.       1300 – 1999 (IOS 12.0 and above)
2.     Extended ACL
a.      Determined Source and Destination IP addresses
b.      100 – 199
c.       2000 – 2699 (IOS 12.0 and above)
Applying ACL:
They can be applied either to the:
·         Outbound interface a router
·         Inbound interface of a router
Standard ACLs within Number:
Example; create an ACL that: permit any IP address that are sourced from subnet mask 172.16.10.0 255.255.255.0
R1(config)# acces-list number Permit/deny Source_IP wildcard_mask
R1(config)# access-list 1 permit 172.16.10.0 0.0.0.255
If we determine a single IP address, it can be done in two ways:
R1(config)# access-list 1 permit 172.16.10.250 0.0.0.0
R1(config)# access-list 1 permit 172.16.10.250
R1(config-if)ip address 10.10.10.1 255.0.0.0
R1(config-if) ip access-group 1 in or out
Standard ACLs within Name:
R1(config)# ip access-list standard Test permit 172.16.10.0 0.0.0.255
ACL Remark:
IOS version 12.0(T) supports remarks (comments) and 100 characters are allowed.
R1(config)# access-list 1 remark permit only traffic from Corporate network is allowed
R1(config)# access-list 1 permit 172.16.10.0 0.0.0.255


NAT (Network Address Translation)

Router

Router

Router a device that connect different network together and it is layer three device. A router is used for WAN network.
There are three kinds of routers in Cisco’s routers
1.      Access layer
2.      Distribution layer
3.      Core layer 4600 – 60000
Many companies manufacturing router:
1.      Cisco
2.      Nortel
3.      MultiCom
4.      Cyclades
5.      Juniper
6.      Dlink
7.      Linksys
8.      3com
But Cisco is having monopoly in the market of routers.
Note:
There are fixed devices and modulator
Fixed Devices: You cannot change the interfaces or ports
Modulator: You can insert and change interfaces
Router Interfaces:
1.      LAN Interfaces
2.      WAN Interfaces
3.      Management Interfaces
a.      Console – is used for initial configuration
b.      Auxiliary interfaces – outside configuration – connect to a modem. But public IP should be assigned to the router.
Router Mode:
1.      User mode
2.      Privilege mode (show, copy, write, reload)
3.      Global Configuration mode (hosname, interface, enable secret…)
4.      Setup mode
5.      X*Boot mode ( In this mode you can recover the password if lost it)
a.      It is also called router’s maintenance mode
b.      Press the break key (console connection) for 60 sec
Routing Protocols
There is a database in router which is called Routing Table. All data are stored in this table. And there are basically two kinds of routing:
1.      Static Routing protocols
2.      Dynamic Routing Protocols
Static Routing:
·         It is used in small companies
·         It has high security
·         Better performance
·         Better management,
·         Better Monitoring and maintenance.
·         Network administrator has to have all information about protocols and routers
·         Network administrator has to set the information to all routers manually.
Static Routing Configuration
R1(config)# ip route
R1(config-rout)# ip route source_Network subnet mask Destination_Network_IP-interface
R1(config-route) ip route 192.168.1.0 255.255.255.0 172.17.1.1
R1(config-route) ip route any any subnet mask interface-IP
R1(config-route) ip route 0.0.0.0 0.0.0.0 172.17.1.1
Dynamic Routing:
It is used with big companies and large networks. And the network administrator don’t have to set information to all devices. There three kinds of dynamic routing protocol:
1.      Distance Victor: send data to near routers, like RIP 1 and IGRP
2.      Links State: Before send data to other routers. It first try have a complete image of all network, like OSPF.
3.      Hybrid
Autonomous System:
A collection networks under a common administrative domain. And it start from 0 -65535.
IGP (Interior Gate Protocol)
It operates in AS and it is used for internal communication in a company through a country like RIP, IGRP, and OSPF.
EGP (Exterior Gate Protocol)
It operates within different AS. Like ISIS, Frame Relay…
IANA: Controls all AS in the world.
NIRA (National Intent Registry of Afghanistan)
It gives AS number to Telecommunications Company. Like Roshan, AWCC, ISP. And uses IGP protocols like OSPF, RIP and…

IANA

NIRPK

AWCC

Bahador

P

Z

Y

X

To connect different AS like Afghanistan and Pakistan, we must use EGP protocol. By activating of BGP which is one EGP’s protocol we can create communications.






NIRA
      AS: 110                                                                                                             AS: 169

Roshan






       Single Autonomous - IGP                                                       Single Autonomous - IGP












Dynamic Routing Protocols: VLSM supporting or not supporting
1.      Classless Routing
2.      Classful Routing 
RIP (Routing Information Protocol)
·         Oldest protocol and public protocol. It is from IGPs
·         RIP works in AS
·         It is Distance-Victor
·         RIP updates every 30 seconds routing table by 255.255.255.255
·         It has two types: RIP v1 and V2
·         It is hop count protocol and its metric up 15 routers
·         Load balancing
·         RIP v1 is Classful routing protocols
RIP has 4 times by default:
1.      Update timer: 30 sec
2.      Invalid timer: 180
3.      Hold-down timer: 180
4.      Flush timer: 240

172.17.10.1

172.17.20.1

172.17.40.1

172.17.60.1

172.17.50.1

172.17.70.1

R1

R2

R3

SW2

SW1

SW4

SW3

SW5

SW6

172.17.30.1

172.17.80.1










The following steps are RIP protocol activation of above diagram:
R1 (config)# router rip
R1 (config)# network 172.17.30.0
R1 (config)# network 172.17.20.0
R1 (config)# network 172.17.10.0

R2 (config)# router rip
R2 (config)# network 172.17.10.0
R2 (config)# network 172.17.80.0
R2 (config)# network 172.17.70.0
R2 (config)# network 172.17.40.0

R3 (config)# router rip
R3 (config)# network 172.17.40.0
R3 (config)# network 172.17.50.0
R3 (config)# network 172.17.60.0
Now all devices can communicate to each other because they are routed. Now if they want to communicate, they check their routing table.
IGRP (Interior Gateway Routing Protocol)
1.      Created by Cisco in 1980
2.      Used in large network
3.      Using one AS
4.      Sending information to other routers every 90 seconds
5.      Uses different times
a.      Update timer
b.      Invalid timer
c.       Hold down timer
d.      Flush timer
6.      Its configuration same as RIP plus AS number
7.      New routers don’t support IGRP

IGRP Configuration:
R1(config)# router IGRP 102
R1(config-router)# network 172.17.30.0
R1(config-router)# network 192.168.1.0
EIGRP (Enhanced Interior Routing Protocol)
1.      Works in AS
2.      Lager networks
3.      Must have AS number From ISP or MCIT
4.      Works with any topology and media
5.      High speed
6.      Taking backup and saving in topology table
7.      It has three table
a.      Neighboring Table
b.      Topology Table
c.       Xxxx
8.      Its configuration is like IGRP
OSPF (Open Shortest Path First)
1.      It is also IGP protocol
2.      It is link-state victor protocol
3.      It has two area for its configuration
a.      Single area
b.      Multi area
4.      It was created in 1988 by IETF
5.      It advertises its info every 30 seconds
6.      Wild card mask is used in its configuration
OSFP Configuriation Steps:
R1(conf)# router ospf AS_number
R1(conf-router)# network network_range wildcard mask area 0
R1(conf-router)# network 192.168.0.0 0.0.255.255 area 0
R1(conf-router)# network 172.17.1.0 0.0.0.255 area 0
R1(conf-router)# network 10.0.0.0 0.255.255.255 area 0

Some other commands for OSPF
·         Show ip route
·         Show ip protocols
·         Show ip ospf neighbor


·         Show ip ospf interface